Video clip won't load or play properly

Top  Previous  Next

1) You have played similar clips before without problems:

 

If you have changed settings in the Sub Machine program (eg. device type or scene change detection or showing of thumbnails) that may be the explanation. Change them back and try again

 

If you have installed new hardware or software, that may be the cause. Try changing them back or

 

Try running an old clip that you know is working to see if the problem is the clip itself or general.

 

Run System Restore

 

 

2) This is the first time you try to play a clip or a new clip type:

 

As a general rule a video clip with an *.avi, *.wmv or *.mpg extension that runs in Windows Media Player will also run in Sub Machine. But sometimes there may be a problem.

 

A normal error message in such a case will be "error rendering file".

 

First of all, the easist way to avoid the problem is to run your clip through our internal converter. That will solve most problems in this category.

 

If you do insist on using the original clip instead of converting, install the LAV codecs.

 

If there still are problems, first check if the video interface isn't blocked by a webcam or another device. Select Options/Setup/video configuration/standard video device. In the "select video device" window, make sure "No video device" is chosen.

 

If that does not work, try to untick either the "Enable scene change detection" or "Enable thumbnails" options or both under Setup/videoconfiguration/scene change.

 

If the file loads, but is out of sync or otherwise uneven, try selecting Options/video configuration/video cache and use hardware resizing.

 

If this does not do the trick, you may have a file that requires a codec that is not present or overridden by other codecs. If you do not know what "codec" means, please take a short detour via this link.

 

If you haven't already installed it, download the freeware tool GSpot from http://www.headbands.com/gspot/download.html

 

Gspot will tell you what codec you need. If the codec isn't present, you must find it and install it (use Google). But do avoid so called "codec packs" that will install a load of things that will probably mess up your system. Stick to the codec you need and nothing else. And if the thing still won't run, then convert it to a usable avi format, preferably with an MJPEG or MPEG4 codec. Use our internal comverter, Virtual Dub or the VirtualDub MPEG2 clone for the conversion.

 

 

clip0504

 

GSpot yields a plethora of information about any video clip.

 

Use Gspot's lower window, "Proposed Codec solutions and Tests" to find out if the clip will run - and why not if it won't. Click the numbers (1, 2, and 3). The available filters will be shown in the system's preferred sequence. The upmost solution is the one that will be used. If you want to change the filter priority, go here.

 

 


Nero Mp4 Splitter - a pain in the butt

 

If you have problems framestepping - that is moving the clip one frame forwards and backwards using Numpad7 or Numpad9, this little bastard could be the culprit. Remove it with the Debug function.

 


Mainconcept - a royal pain in the butt

 

If the Mainconcept codec is installed, it will override anything else and generally create havoc. It's not easy to uninstall Mainconcept. But with the newest versions of Gspot and Filmerit it is possible to find the paths of the annoying files and neutralize them. Also the K-Lite codec pac may cause trouble. Generally avoid these public codec packs. Uninstall them and manually install the codecs you need. Or remove (some of) them with the Debug function.

 


DirectVobSub - an imperial pain in the butt

 

If anybody installs a codec pack that contains the "DirectVobSub" filter, they will need to disable or uninstall "DirectVobSub" since it will cause a long delay before the movie starts and sometimes even turn your picture upside down. So if you are having this kind of problem, please download Filmerit and check for the existence of the "DirectVobSub" filter, which can be part of the following codec packs: K-Lite,  Xp , Matroska, and Nimo codec packs, but there are probably others that contains "DirectVobSub". As a workaround FFDshow can be used to show subtitles instead of "DirectVobSub". But best action is to remove them. Use the Debug function.

 


 

 

See also:

An excellent aid: VirtualDub

How to recompress video clips

Setting codec priority

Video resizing

Debug